اگر سیستم عامل Debian 9 را با استفاده از یک فایل image نصب کرده اید، سیستم شما احتمالا تمام منابع مورد نیاز که در فایل لیست منابع متداول موجود است را ندارد. این می تواند به خطایی مانند E: unable to locate package منجر شود. در تصویر زیر می توانید رخ دادن این ارور را هنگام نصب openssh-server مشاهده کنید :

رخ دادن ارور هنگام نصب یک بسته در دبیان 9

در ادامه روشی برای رفع این ارور بیان شده است.


هنگامی که شما به فایل etc/apt/sources.list/ نگاه میکنید، منابع پیشفرض موجود در تصویر زیر نشان داده شده است :

منابع پیش فرض موجود در دبیان 9

برای رفع این خطا، شما باید منابع نرم افزارهای لازم سیستم عامل Debian را در فایل etc/apt/sources.list/ با استفاده از دستورات زیر اضافه کنید:

deb  http://deb.debian.org/debian  stretch main
deb-src http://deb.debian.org/debian stretch main

توجه کنید که در صورتی که می خواهید از اجزا و بسته های غیر رایگان استفاده کنید باید از دستورات زیر استفاده کنید :

deb  http://deb.debian.org/debian stretch main contrib non-free
deb-src http://deb.debian.org/debian stretch main contrib non-free

پس از اجرای دستورات بالا، فایل را ذخیره کرده و ببندید. سپس با استفاده از دستور زیر لیست بسته های سیستم خود را به روز رسانی کنید :

# apt update

پس از اتمام فرایند بالا سعی کنید تا برنامه یا بسته مورد نظر خود را دوباره نصب کنید.

برچسب ها :
لینک کوتاه:     www.errorpedia.ir/s/a804b
منبع : www.tecmint.com

مطالب مرتبط

نظر شما

لطفا نام و نظر خود را در فرم زیر وارد کرده تا در صورت تایید برای کاربران نمایش داده شود.




متن تصویر:

نظرات کاربران

هیچ نظری تا کنون ثبت نشده است